EOI - 2x non-functioning Atomic CLRs

ATTENTION! IF YOU DON'T HAVE 100 POSTS THEN DON'T POST FOR SALE THREADS. THIS IS NOT A FORUM WHERE YOU GET FREE SALES WITHOUT HAVING SOME INVOLVEMENT WITH THE COMMUNITY. IF YOU DON'T HAVE THE RIGHT NUMBER OF POSTS, DON'T BOTHER ASKING WHERE YOUR THREAD WENT.
Cheers.

Moderator: Capt. Black

Forum rules
ATTENTION! IF YOU DON'T HAVE 100 POSTS THEN DON'T POST FOR SALE THREADS. THIS IS NOT A FORUM WHERE YOU GET FREE SALES WITHOUT HAVING SOME INVOLVEMENT WITH THE COMMUNITY. IF YOU DON'T HAVE THE RIGHT NUMBER OF POSTS, DON'T BOTHER ASKING WHERE YOUR THREAD WENT.
Cheers.
Kiwiaxe
Vintage Post Junkie
Vintage Post Junkie
Posts: 2362
meble-kuchenne.warszawa.pl
Joined: Fri May 21, 2010 10:08 pm
Has liked: 11 times
Been liked: 278 times

EOI - 2x non-functioning Atomic CLRs

Post by Kiwiaxe »

Long story short.

I have two Atomic CLR cabs, with speakers all intact and one even has a studio slip padded cover. But the amp modules in both are toast.

I sent one unit back to Atomic in the USA. 18 months later and US$400 the poorer (after they said they fixed it), it returned still non-functional. They've since not responded to any emails. Bastards.

So I figure these are two well made cabs, with supposedly good speakers (Eminence something rather, supposedly what they make for FRFR use), and one with a nice padded cover. I could either try to make some use of them myself. But they'd likely sit in storage for another year or two before I did anything. So - does anyone have any interest in these and have something of interest to flick my way?

User avatar
olegmcnoleg
Vintage Post Junkie
Vintage Post Junkie
Posts: 4184
Joined: Sat Dec 21, 2013 11:26 am
Location: Awkland
Has liked: 834 times
Been liked: 803 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by olegmcnoleg »

Kiwiaxe wrote: Mon Dec 27, 2021 8:10 pm Long story short.

I have two Atomic CLR cabs, with speakers all intact and one even has a studio slip padded cover. But the amp modules in both are toast.

I sent one unit back to Atomic in the USA. 18 months later and US$400 the poorer (after they said they fixed it), it returned still non-functional. They've since not responded to any emails. Bastards.

So I figure these are two well made cabs, with supposedly good speakers (Eminence something rather, supposedly what they make for FRFR use), and one with a nice padded cover. I could either try to make some use of them myself. But they'd likely sit in storage for another year or two before I did anything. So - does anyone have any interest in these and have something of interest to flick my way?
That’s a sad story. How much do you want for them? And any idea why the power amps failed?

Kiwiaxe
Vintage Post Junkie
Vintage Post Junkie
Posts: 2362
Joined: Fri May 21, 2010 10:08 pm
Has liked: 11 times
Been liked: 278 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Kiwiaxe »

No idea why the amps failed, although google suggests it’s not as isolated a problem as one would wish for.

As far as what I want for them - no idea. Not quite F All. But probably after something fun rather than cash. A cool pedal and some donation to the forum…

User avatar
Zaulkin
Vintage Post Junkie
Vintage Post Junkie
Posts: 5008
Joined: Thu Nov 27, 2008 4:01 pm
Has liked: 782 times
Been liked: 473 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Zaulkin »

I sold someone my old one and it eventually had the same issue. Just like you, they ignored my emails. Eventually got a response - The repair quote was nuts.

Just a hunch, but I think they just come up with feasibly cool ideas and mass produce them in China without proper QC. The amplifire pedals had loads of issues.

User avatar
robthemac
Vintage Post Junkie
Vintage Post Junkie
Posts: 3534
Joined: Sun Apr 28, 2019 3:47 pm
Has liked: 851 times
Been liked: 738 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by robthemac »

I'd spam all their social media pages until you get a response.

User avatar
Bg
Site Admin
Posts: 38352
Joined: Fri Sep 05, 2003 12:13 am
Location: Auckland
Has liked: 2250 times
Been liked: 3443 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Bg »

I use one as a bass cab, works a treat!
So, is that low alcohol or no alcohol at all? mmmm, no alcohol, do you want to try it? Noooooooooo.

User avatar
opsguy
Fender
Fender
Posts: 552
Joined: Thu May 12, 2005 7:59 pm
Location: Auckland
Has liked: 461 times
Been liked: 152 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by opsguy »

BG has my old one. Same issue as Kiwiaxe. I tried getting it fixed through the local distributor and Atomic in the US. They shagged me around for 2 years and in the end stopped replying. I told them I would pay for the fix and the freight etc, they were disingenuous at best. I would never recommend an Atomic product to anyone, nor would I use the NZ distributor again. I replaced it with a line 6 powercab and it has been flawless, would recommend.

User avatar
Cdog
Vintage Post Junkie
Vintage Post Junkie
Posts: 3748
Joined: Wed Feb 07, 2007 3:01 pm
Location: Christchurch
Has liked: 2353 times
Been liked: 469 times
Contact:

Re: EOI - 2x non-functioning Atomic CLRs

Post by Cdog »

Bummer! That's a bit of a gear horror story there 🙁

User avatar
jeremyb
Chorus of Organs
Posts: 31435
Joined: Sat Dec 06, 2008 9:03 am
Has liked: 5616 times
Been liked: 3011 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by jeremyb »

Yikes, and not like they were cheap either!
Birds aren’t real.

Kiwiaxe
Vintage Post Junkie
Vintage Post Junkie
Posts: 2362
Joined: Fri May 21, 2010 10:08 pm
Has liked: 11 times
Been liked: 278 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Kiwiaxe »

If someone was more electronic-smart than me (not hard), I’d have thought it wouldn’t be too hard to make a passive crossover for each at appropriate settings, and then one could use one of various class-d amp options

User avatar
Kris
Vintage Post Junkie
Vintage Post Junkie
Posts: 3645
Joined: Mon Nov 29, 2010 1:52 pm
Location: Under a bridge,somewhere in chch.
Has liked: 106 times
Been liked: 421 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Kris »

I was going to say,a lot of them have chinese class-d amps in them.You could prob just replace the power section with one of those for a fraction of what they would charge.or a potential new owner could!

User avatar
Bg
Site Admin
Posts: 38352
Joined: Fri Sep 05, 2003 12:13 am
Location: Auckland
Has liked: 2250 times
Been liked: 3443 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Bg »

I'd take another if going for peanuts ;)
So, is that low alcohol or no alcohol at all? mmmm, no alcohol, do you want to try it? Noooooooooo.

User avatar
Bg
Site Admin
Posts: 38352
Joined: Fri Sep 05, 2003 12:13 am
Location: Auckland
Has liked: 2250 times
Been liked: 3443 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by Bg »

opsguy wrote: Tue Dec 28, 2021 8:34 am BG has my old one. Same issue as Kiwiaxe. I tried getting it fixed through the local distributor and Atomic in the US. They shagged me around for 2 years and in the end stopped replying. I told them I would pay for the fix and the freight etc, they were disingenuous at best. I would never recommend an Atomic product to anyone, nor would I use the NZ distributor again. I replaced it with a line 6 powercab and it has been flawless, would recommend.
It works nicely as a not heavy bass speaker :) Sadly the bugger-a amp weighs 3 times as much :D
So, is that low alcohol or no alcohol at all? mmmm, no alcohol, do you want to try it? Noooooooooo.

User avatar
rickenbackerkid
Vintage Post Junkie
Vintage Post Junkie
Posts: 6382
Joined: Thu Apr 28, 2005 1:52 pm
Has liked: 196 times
Been liked: 597 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by rickenbackerkid »

Incredibly shocking service. Wow.

User avatar
MattAnt
Vintage Post Junkie
Vintage Post Junkie
Posts: 1356
Joined: Sun May 20, 2012 2:31 pm
Has liked: 16 times
Been liked: 206 times

Re: EOI - 2x non-functioning Atomic CLRs

Post by MattAnt »

Well this doesn’t make me feel great about the CLR I bought off ya!
Scarecrow101 on TradeMe

Post Reply