Discuss the stuff that makes your ears bleed.

Moderators: Slowy, Capt. Black

User avatar
BY KNNZ
#689815
Hey guys, so my Laney Cub12R is crapping out, just changed new set of 12AX7 tubes but still not helping, I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business? Correct me if I'm wrong though, phoned them numerous times but no replies.

I'm a tube amp noob so I have no idea what's wrong with it, anybody in Aux can repair or have a look to see what's wrong?
ANy help much appreciated!!
User avatar
BY Conway
#689818
KNNZ wrote: I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business?

:?: :!:
User avatar
BY Molly
#689823
Conway wrote:
KNNZ wrote: I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business?

:?: :!:


I had an email from Ryan just this past week. Recently back from a break. I'd assumed that maybe he'd just been on holiday and was now back at the helm.
User avatar
BY KNNZ
#689824
Molly wrote:
Conway wrote:
KNNZ wrote: I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business?

:?: :!:


I had an email from Ryan just this past week. Recently back from a break. I'd assumed that maybe he'd just been on holiday and was now back at the helm.


The whole shop was empty with only lots cobwebs spider webs lol, not one single wire inside, maybe was for security purposes, but thanks for the info Molly, I'll have to return and have another look
User avatar
BY KNNZ
#689830
MattAnt wrote:Clarry without a doubt if you are ok going to Titirangi for drop-off/pickup


thanks Matt how do I get hold of Clarry?
User avatar
BY jvpp
#689834
34 AUDIO  
Audio Visual Equipment Repair Service
Address: 6 Kohu Rd, Titirangi, Auckland 0604, New Zealand
Phone:+64 9-817 2634
User avatar
BY KNNZ
#689839
jvpp wrote:34 AUDIO  
Audio Visual Equipment Repair Service
Address: 6 Kohu Rd, Titirangi, Auckland 0604, New Zealand
Phone:+64 9-817 2634


cheers bro! :thumbup:
User avatar
BY Capt. Black
#689843
If you look at the front window of the Ampshop, you'll see a sign saying that the shop is now online only.
Not gone out of business. Just relocated to the ether.
It also says Ryan is still doing repairs and servicing. Just contact him through the Ampshop.co.nz webstore.

And Clarry is great.
User avatar
BY Bg
#689845
Yeah he's closed the shop down, but is still working :)
User avatar
BY Olderama
#689846
KNNZ wrote:Hey guys, so my Laney Cub12R is crapping out, just changed new set of 12AX7 tubes but still not helping, I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business? Correct me if I'm wrong though, phoned them numerous times but no replies.

I'm a valve amp noob so I have no idea what's wrong with it, anybody in Aux can repair or have a look to see what's wrong?
ANy help much appreciated!!

Out of interest is it just turning off
I had the same issue and the thermal thingimidoodle had to be removed

Cheers
User avatar
BY KNNZ
#689849
Olderama wrote:
KNNZ wrote:Hey guys, so my Laney Cub12R is crapping out, just changed new set of 12AX7 tubes but still not helping, I went to the AmpShop but the whole shop was empty?? Looks like Ryan's gone out of business? Correct me if I'm wrong though, phoned them numerous times but no replies.

I'm a valve amp noob so I have no idea what's wrong with it, anybody in Aux can repair or have a look to see what's wrong?
ANy help much appreciated!!

Out of interest is it just turning off
I had the same issue and the thermal thingimidoodle had to be removed

Cheers


the what had to be removed??
It sort of turns off, the volume fluctuates, then suddenly there's no sound, switch it off, turn on couple hours later and works but same thing happens again